La funzione Excel più utile che tu possa imparare

Questo post è disponibile anche in: Inglese

Vorrei presentare la funzione più utile che Excel ha da offrire.

Questa è la funzione Excel più utilizzata nel Fast Excel Development Method. Quando costruisco sistemi di pianificazione, mi ritrovo a digitare questo nelle formule più di qualsiasi altra funzione.

Tale funzione può trasformare i fogli di calcolo Excel in una piattaforma software aziendale completa. Lo usiamo per recuperare dati, eseguire calcoli e presentarli in un report.

 

La funzione magica INDICE.

Anche se hai familiarità con INDICE e l’hai già usata, scommetto di poter rivelare alcuni trucchi che potresti non aver scoperto. Mi considero un power user di Excel, ma sono sicuro che qualche guru di Excel nei commenti mi darà un nuovo suggerimento sull’utilizzo di INDICE che non conosco.

Questo è il potere di INDICE.

Che cosa fa INDICE?

INDICE restituisce un valore o un riferimento a una cella, in base a una coordinata in un intervallo. Ecco gli input:

=INDICE(Matrice; Riga; Colonna)

La matrice può essere monodimensionale (A1:A8) o bidimensionale (A1:C8).

Diamo un’occhiata a un esempio. Ecco una semplice tabella Example Excel Table for INDEXthat descrive le quantità di frutta in determinati giorni della settimana. Se applico la formula:

= INDICE (B1:B8; 4)

essa si posizionerà nell’intervallo B1: B8 nella quarta cella e restituirà il suo valore: “Arance”.

= INDICE (A1:C8; 5; 2)

restituirà la 5a riga e la 2a colonna dell’intera tabella A1:C8: “Bananas”.

Puoi anche utilizzare riferimenti di colonna completi (A: A),

o nomi di zona, ad es. “Fruit_Table” dove Fruit_Table = Sheet1!$A$1:$C$8

oppure ;

Fruit_Table=
SCARTO(Sheet1!$A$1;0;0;CONTA.VALORI (Sheet1!$A:$A);CONTA.VALORI(Sheet1!$ 1:$1)).

Ulteriori informazioni sugli nomi di zona dinamici di seguito.

L’applicazione più comune per INDICE

INDICE è più ampiamente utilizzato come parte di una formula di ricerca. Molti utenti di Excel hanno familiarità con CERCA.VERT per restituire un valore da una tabella quando si dispone di un altro valore dalla stessa riga.

Se combinato con CONFRONTA, INDICE è un metodo di gran lunga superiore. Ecco come funziona:

Stile Esempio di ricerca INDICE CONFRONTA

CONFRONTA cerca un valore in un intervallo e quindi ne restituisce la posizione. Il risultato di CONFRONTA è un numero.

Supponiamo di voler sapere quale frutta è stata consumata mercoledì.

= INDICE(B1:B8;CONFRONTA(“mercoledì”; A1:A8; 0))

= INDICE (B1:B8;4) = “Arance”

Una combinazione di INDICE, CONFRONTA viene utilizzata sempre nelle applicazioni per fogli di calcolo per recuperare un valore da una tabella.

Ora, perché è meglio del vecchio fidato CERCA.VERT?

Per cominciare, è molto più veloce. La maggior parte dei lavori di ricerca richiede più di un valore dalla stessa tabella. L’elaborazione di CONFRONTA richiede un utilizzo intensivo del computer, ma è necessario eseguirlo una sola volta. In una colonna possiamo restituire il numero di riga e applicarlo a più INDICE.

CERCA.VERT è anche rigido poiché dipende dalla restituzione di una colonna relativa alla tabella. Se non mi credi, prova a cercare un valore che si trova a SINISTRA della colonna di ricerca.

INDICE può restituire valori sia di riga che di colonna, quindi puoi utilizzarlo per trovare un valore in una tabella utilizzando sia il nome del campo che il valore di ricerca.

= INDICE(Fruit_Table;CONFRONTA(“Wednesday”;A1:A8;0), CONFRONTA(“Fruit”;A1:C1;0))

Utilizzo più avanzato di Excel con INDICE

Per il vero potere di INDICE, possiamo ottenere un indizio dalla definizione

“INDICE restituisce un valore o un riferimento …”

Ciò significa che può recuperare un valore da una cella – “Arance” – o il riferimento di cella – B4. Ci sono solo poche funzioni di Excel che possono restituire un riferimento. (INDIRETTO, SCARTO essendo gli altri notevoli).

Se possiamo ottenere un riferimento di cella, possiamo usarlo come sostituto di un indirizzo di cella.

= INDICE(C1:C8;2) = C2

= INDICE(C1:C8;8) = C8

Perciò

INDICE(C1:C8;2):INDICE(C1:C8;8) = C2:C8

e SOMMA(INDICE(C1:C8;2):INDICE(C1:C8;8)) = SOMMA(C2:C8) = 39

Questo metodo è potente perché ti consente di fare riferimento a un intervallo utilizzando la formula. In combinazione con una procedura di ordinamanento, è possibile utilizzare INDICE:INDICE per trovare un intervallo che rappresenta un sottoinsieme di una colonna lunga.

Ecco un articolo sull’utilizzo di ordinamento e INDICE per analisi rapida su oltre 65.000 righe di dati . SOMMA.SE, CONTA.SE ecc. Sarebbero estremamente lente su tabelle di grandi dimensioni. L’ordinamento e INDICE funzionano entrambi alla velocità della luce e possono battere qualsiasi formula che preveda la ricerca e il calcolo dei valori in lunghe colonne di dati.

INDICE e nomi di zona dinamici

I nomi di zona dinamici sono fondamentali per l’automazione di Excel. Crescono e si restringono per adattarsi ai dati in una tabella. Ciò significa che quando si collega Excel a un sistema host e i dati di input cambiano sempre, il riferimento alla tabella cambia con esso.

Per una descrizione completa dei nomi di zona dinamici, iscriviti al nostro E-learning Fast Excel . Questo ti mostrerà come utilizzare questa tecnica per costruire potenti sistemi di pianificazione e programmazione in grado di elaborare un flusso dinamico di dati aziendali.

Tuttavia, puoi vedere una buona introduzione ai nomi di zona dinamici su OZGrid utilizzando OFFSET . ExcelHero di Daniel Ferry ha una buona interpretazione di creazione di nomi di zona di intervalli di zona dianamici con INDICE .

Potresti anche creare un intervallo denominato dinamico che si riferisca solo alla colonna Giorno (A1: A8) utilizzando SCARTO o INDICE

=SCARTO(A1;0;0;CONTA.VALORI(A:A);1)

=A1:INDICE(A:A;CONTA.VALORI(A:A))

Fai la tua scelta. Usiamo SCARTO nel metodo Fast Excel come convenzione. Non ho notato molta differenza di prestazioni. Se la tua esperienza suggerisce il contrario, sono aperto alla correzione.

INDICE in un’applicazione Excel

La maggior parte delle applicazioni aziendali funziona recuperando i dati dalle tabelle, eseguendo alcuni calcoli e quindi presentandoli al processo successivo. Il software aziendale di solito si trova su database relazionali di grandi dimensioni e deve acquisire rapidamente i record di dati da queste tabelle. INDICE replica questa funzione di database, solo dalle tabelle del foglio di calcolo anziché dai database.

Nel Fast Excel Development Method ti invitiamo a utilizzare archiviazione, calcolo e reporting separati dei dati. Altrimenti commetti l ‘ errore più grande nell’utilizzo di Excel per qualsiasi tipo di applicazione aziendale automatizzata.

I dati possono provenire da un database, venire importati in Excel da file di testo o query ODBC. Una volta che la tabella è in un foglio di calcolo, INDICE e CONFRONTA possono iniziare a funzionare.

INDICE è l’abilitatore per spostare i dati da una posizione di archiviazione, attraverso tabelle di calcolo e quindi in una tabella finale che alimenta un report. Imparalo e diventerà il tuo strumento preferito per i fogli di calcolo.

Altre applicazioni utili per INDEX? Fatecelo sapere nei commenti qui sotto!

Lascia un commento

Torna su